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PivotTables For Excel 2002 
Microsoft PivotTable® technology in Microsoft Excel version 2002 is one of those powerful Excel features that seem a bit baffling the 
first time you try them. But take heart—you just need a little practice. Once you start really experimenting with PivotTable reports, 
you'll learn that this interactive, highly customizable form of displaying data gives you great flexibility in the way you view and 
present the data in your worksheets. And that gives you the opportunity to look good in a new way. 

More than a simple data table, a PivotTable report allows you to group information—by date, by value, or by category—and display 
varying levels of detail. And best of all, you can change the data items you display on-the-fly, which means you can select different 
data groupings in the middle of meetings, in front of a client, or as you're pitching your project to that network big-wig. 

For this article, below there has been created an example on how to create a PivotTable report based on a spreadsheet that tracks 
radio advertisements for Contoso, Ltd., a fictitious online radio station. 

Organize Your Data 

A PivotTable can be as easy or complex as your data needs warrant. Figure 1 shows a snippet of a basic spreadsheet for Contoso. 

 
 
Figure 1: Example Spreadsheet 

The spreadsheet is organized as a data list, which means the data items are organized in columns, and row labels are not used (this 
is how the PivotTable Wizard will want to see your data, too). Important data items in this spreadsheet include the client, the region 
in which the ad was sold, the length of the ad, the number of times the ad is run, the sales rep who sold the ad, and, of course, the 
revenue generated. (Let's not forget the bottomline!) 

Know What You Want To Do with Your Data 

Now you may be wondering how to make the PivotTable report show what you want it to show. That's the most important part of 
creating an effective PivotTable report: You need to know what you want to see. I've found it helpful to put what I want to learn in the 
form of a question: 

• How many 30-second spots did we sell for October?  
• What's the average length of the commercial sold?  
• Who sold the most commercials for October? In which region?  

A PivotTable report is great for displaying different collections of data in a spreadsheet in different ways. Because you can choose 
and rechoose the data items you want to show, and reorder and redisplay them, you can display your information in numerous ways 
until it shows what you want to see in the best, most accurate way. 
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Let the Wizard Lead the Way 

Once you know what you're trying to portray, the next step is simple. Excel generates the PivotTable report by giving you a 
PivotTable Wizard as a guide. Here's the process in a nutshell: 

1. Click in the worksheet you want to use to create the PivotTable.  
2. On the Data menu, click PivotTable and PivotChart Report.  
3. Under Where is the data that you want to analyze?, you need to choose the location of the data you want to use. 

You will have the choice of four option buttons. Your choices are Microsoft Excel list or database (which is what 
we're using in this example), External data source (such as a spreadsheet or data table you're importing from another 
program), Multiple consolidation ranges (where you're combining multiple areas on a worksheet), or Another 
PivotTable or PivotChart report.  

4. Under What kind of report do you want to create?, choose PivotTable. Click Next.  
5. The wizard asks you to choose the data range you want to use. If the Range field automatically selects the range, click 

Next. If you want to specify a different range, click the button to the right of the Range field, select the new range, and 
click the close box to enter the range. Click Next.  

6. Excel then asks whether you want to put the PivotTable report on a new worksheet or an existing worksheet. Until you 
get the hang of PivotTable reports, it's best to put them on their own worksheets. You can always copy and paste them 
where you want them later. Click Finish.  

Note: If you get a warning message saying that the PivotTable report field name is not valid, and that you need to use a list to 
create a PivotTable report, don't panic. Most likely you have used a worksheet with row labels, and Excel wants a list of columnar 
data in which each column heading is a field label and the entries in the rows are the values in the individual fields. Return to the 
step in the wizard in which you select the data range and be sure to select only list data; that is, column headings and values 
beneath them. When you continue with the Wizard, Excel should give you the thumbs-up (figuratively speaking). 

Assemble the PivotTable 

The wizard creates the blank PivotTable report and places it in the new worksheet (assuming that you selected that option). In 
addition to the table form itself, Excel gives you the PivotTable Fields List and the PivotTables toolbar, as Figure 2 shows: 

 
 
Figure 2: PivotTable Report Fields 
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Excel blocks out the different areas for you and shows you what goes where. But how do you know what to use as a page field or a 
row field? Some simple definitions can help make that clearer: 

• Page fields display one data item by which all table values are filtered.  
• Column fields display the column categories for the table.  
• Row fields display the items shown in individual rows.  
• Data fields display the values and calculations.  

To create the PivotTable report, you simply drag the fields from the PivotTable Field List to the areas on the PivotTable report where 
you want to apply them. As soon as you release a field in the PivotTable form, Excel plugs in the data. If you decide that you don't 
want to use a field you've placed in the PivotTable report, simply drag it back to the PivotTable Field List and release it. 

This is the part of creating a PivotTable report that takes a little practice. By moving a few fields around—from row to column to data 
and back—and by adding and removing fields from the table, you'll get a sense of how you can best show your particular data. 

Keep Experimenting Until You Like What You See 

Consider the example in Figure 3. This PivotTable report shows the revenue generated by the sales representatives in each of the 
four different sales regions. 

Play month is the page field. This field controls all the data displayed in the table. Right now the field is set to All, which displays all 
months in the selected data range. If I want to show the spots sold in the various regions only for the month of September, I would 
click the Play month arrow and choose September from the list. As a result, the data values in the table would change. 

Region is the column field, showing North, South, East, and West as the column headings. 

Rep (short for sales representative) is the row field, listing the initials of the different sales reps in the rows of the PivotTable report. 

Sum of Revenue is the data field, placing the revenue dollars in the data items area of the PivotTable report. 

 
 
Figure 3: PivotTable Report 
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Create a PivotChart 

So are you getting the idea that playing with your data is half the secret to creating great PivotTables reports? Not only will you be 
moving fields back and forth from the PivotTables Fields List, but you can use the column, row, and page field arrows to further 
customize the data displayed in the table. 

And when you're ready for a big change, you can paint a chart with your PivotTable data by clicking the PivotChart tool in the 
PivotTable toolbar. Excel draws a bar chart based on the information in the table, displaying the column, row, page, and data fields 
so that you can choose the items you want to display. Figure 4 shows the PivotChart report that Excel created when I clicked the 
PivotChart tool for the PivotTable report. 

The great thing about PivotCharts is that they are as flexible as their tabular cousins; when you change data in the PivotTable report 
later, the chart changes too. 

 
 
Figure 4: PivotChart Graph 

Summing Up 

PivotTable reports have a reputation for being a hard-to-handle high-end geeky tool that only those people who can not leave 
numbers alone can love. Not so. If you crave the freedom and flexibility to display your data the way you want it (and are willing to 
keep working at it until you get just the right effect), you too can become a master PivotTable report artist. And the perks of being 
able to understand and create these tables and charts on your feet may be greater than you think—they just might get you noticed 
by data-hungry executives up to their eyeballs in ho-hum, run-of-the-mill spreadsheets. 
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Excel Tips & Tricks for Excel 2000 

Use AutoFill to Quickly Copy Formulas and Formatting in Excel 
Would you like an easy way to extend a series of numbers in Microsoft Excel without typing each one individually? With AutoFill, 
you can quickly copy data, formulas, or formatting to adjacent cells. This brief tutorial will show you how:  

1. Select the cells that you would like to copy.  
2. Move the cursor to the bottom right corner of the highlighted cells. Your cursor will then turn into a black plus sign.  
3. Click and hold down the right mouse button and drag across the cells you want to fill.  
4. Release the mouse button, and when the shortcut menu appears, click Fill Series.  

By following these steps, you will be able to save a lot of time creating your spreadsheets.  

 

Show or Hide the Formulas in an Excel Spreadsheet 
When you're working in an Excel worksheet, you can alternate between viewing the values in the cells and displaying the formulas. 
To toggle between the different views, press CTRL+` (single left quotation mark).  

Editor's Note: If you're having trouble finding the single left quotation mark, it's on the same key as the "~" symbol. On most 
keyboards, it's the key directly to the left of the "1" key.  

 

Don't Lose Sight of Your Column Headings in Excel 
Would you like to see the column headings on your Microsoft Excel spreadsheets no matter how far down you scroll? Here is one 
way to keep the column headings constantly visible:  

1. Select the row just below your column headings.  
2. On the Window menu, click Freeze Panes.  

 
Figure 5: Frozen Column Headings 
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The "frozen" column headings don't scroll, but remain visible as you move through the rest of the worksheet.  

 

Edit Cells Quickly in Excel—Without Using Your Mouse 
If you like to use your keyboard for everything, editing a lot of data quickly in an Excel spreadsheet can be difficult because you find 
yourself constantly reaching for the mouse when you want to make changes to a cell. But there's a shortcut you can use so that your 
hands never have to leave the keyboard—press F2. Here's how:  

1. Use the arrow keys to select the cell you want to edit.  
2. Then press F2 (or COMMAND-U, if you use a Macintosh computer) to edit the cell contents.  
3. When you're finished, just press ENTER (or RETURN on a Macintosh keyboard) to enter your changes. Or press ESC 

to cancel the changes.  

Editor's Note: This tip is especially handy for editing hyperlinks in Excel because, if you use your mouse to click on a cell with a 
hyperlink, it automatically opens an Internet browser window. Using the keyboard lets you edit hyperlinks with ease.  

 

Create an Excel Chart with the Push of a Button 
This is a very old Microsoft Excel trick. To quickly create a chart, using only your keyboard, select the data you want to plot and then 
press F11. Excel automatically creates the chart for you.  

After you select your cells, press ALT+F1 and you'll get the same result.  

 

Select an Entire Range of Cells in Excel 
In Excel, if you want to quickly select the entire range of cells you're working on, press CTRL+SHIFT+ ASTERISK (*).  

For example, if you have a list of customers in Excel, this command will select the entire list and the column headings, but not the 
empty cells around the list—so you get only the cells you need.  

This tip is different from the Select All command, which selects every cell in the worksheet—even the ones that you are not using.  

 

Insert Copied Cells Between Existing Cells Safely 
If you want to insert a range of copied cells between other rows or columns—instead of pasting over them—there's an easy way to 
do it:  

1. Select the cells you want to copy.  
2. On the Edit menu, click Copy.  
3. Select the area on the worksheet where you want to place the copied cells.  
4. Press Ctrl + SHIFT + Plus Sign (+).  
5. In the Insert dialog box, click the direction you want to shift the surrounding cells, and press OK.  

Now, the copied cells are inserted right where you want them, and none of your existing information is lost.  
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Build Vertical Titles in Excel 
Have you ever wondered how to create a heading for a table that runs vertically along the side of a table instead of above it?  

 
Figure 6: Building Vertical Titles 

 
Here's how I do it:  

1. Select the cell that contains your text as well as the surrounding cells that you want your title to span.  
2. On the Format menu, click Cells, and then click the Alignment tab.  
3. In the degrees text box, enter 90.  
4. Select the Merge cells text box and click OK.  

 

Format Excel Cells Fast 
If you want quick access to the Format Cells dialog box in Microsoft Excel to change things like type style, alignment, or borders, 
select the cell you want to format and press CTRL+1.  

 

Have Excel Save Your Files Automatically  
Have you ever wanted Excel to automatically save your spreadsheets for you so you don't lose your work? Excel 2000 includes a 
feature that saves workbooks automatically at specified intervals, but it's not installed by default. Here's how you can install and use 
the Autosave Add-in:  

First you need to load the add-in, which will add it to your Tools menu:  

1. On the Tools menu, click Add-Ins.  
2. In the Add-Ins available list, select the Autosave Add-in check box and then click OK.  
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Then, to configure and use the Autosave feature:  

1. On the Tools menu, click AutoSave.  
2. Select the Automatic save every check box.  
3. In the Minutes box, enter how often you want Excel to save your workbooks.  
4. Select any other options you want, and press OK.  

 

Quickly Move Between Multiple Excel Workbooks or Worksheets 
When working with several Excel workbooks or worksheets (the individual pages in workbooks) at once, you can quickly move 
between them using shortcut keys.  

• To move between open workbooks, press CTRL+TAB.  
• To move to the next sheet in a workbook, press CTRL+PAGE DOWN.  
• To move to the previous sheet in a workbook, press CTRL+PAGE UP.  

 

Do Fast Calculations in Excel 
Have you ever needed to know the largest value in a series of cells? You can create a formula to do that, but there is a faster way.  

To view the largest value in a series of cells:  

1. Select the cells in which you are interested, and you will see the sum of the range displayed on the status bar, which is 
the horizontal area below the worksheet window.  

2. If the status bar is not displayed, click Status Bar on the View menu.  
3. Right-click the status bar, and then click Max. Now you can see the maximum value displayed on the status bar.  

 
Figure 7: Fast Calculations 

You can use the same technique to find the average of, the sum of, or the minimum value in the selected range. You can also count 
the cells that contain numbers (by selecting Count Nums) or count the number of filled cells (by selecting Count).  
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Completely Delete Cells in Excel Using This Shortcut 
Have you ever wanted a keyboard shortcut that completely deletes a cell from your worksheet, including the formatting and 
comments? Just select the cells you want to delete, and then press CTRL+MINUS SIGN (–). The surrounding cells will shift to fill the 
space.  

This is different from using the DELETE or BACKSPACE keys, which simply clears the contents of a cell without actually deleting it.  

 

Copy the Contents of an Entire Worksheet in Excel  
Here's a timesaving tip for Excel users who frequently need to copy an entire worksheet (a page within a workbook) of information—
such as a list of items for a monthly inventory—from one workbook (Excel file) to another.  

To copy an entire sheet to another workbook:  

1. Open the workbook into which you want to paste the copied sheet.  
2. Switch to the workbook that contains the sheet you want to copy.  
3. Right-click the Sheet tab of the sheet you want to copy, and then click Move or Copy on the shortcut menu.  
4. From the To book drop-down menu, select the workbook that will receive the sheet. (To copy the selected sheet to a 

new workbook, click New book on the drop-down menu.)  
5. Select the Create a copy check box. (If you don't select this check box, the sheet will be moved instead of copied.)  
6. Click OK.  

 

Do Creative Calculations with Paste Special 
I find this trick fantastically useful. If you have a block of numeric data in an Excel worksheet and you wish to change each entry to a 
negative value, use Paste Special with a twist.  

Here's how:  

1. In an empty cell, type -1.  
2. Select the cell, and click Copy on the Edit menu.  
3. Now select the cells containing the values you want to change.  
4. On the Edit menu, click Paste Special.  
5. Under Paste, click Values and under Operation, click Multiply.  
6. Click OK.  

All the numbers change from positive to negative, or vice versa. This method is also useful for reducing numbers by a factor of 
1,000, 1,000,000, and so on.  

 

Quickly View All Worksheet Formulas in Excel 
With a quick keystroke, you can display all the formulas in your worksheet, including the serial values Excel uses to store dates.  

To alternate between displaying cell values and displaying cell formulas, press CTRL+` (single left quotation mark, which usually 
can be found above the TAB key).  
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Add a Calculator to the Excel Toolbar 
Did you know that you could add a calculator to your Microsoft Excel toolbar? Here's how:  

1. On the View menu, click Toolbars, and then click Customize.  
2. Click the Commands tab.  
3. In the Categories list, click Tools, and in the Commands list, click Custom (the one with the gray calculator graphic).  
4. Drag the selected command from the Commands list to a toolbar. (Lift your finger from the mouse when you see a plus 

sign next to your pointer.)  
5. Click Close.  

Now click the button you just added to run the calculator.  

 

Paste Information from Excel as a Picture 
Do you want to place an image of an Excel file into a Word document, image editing program, or other program? It's easy to do.  

1. On the Excel worksheet or chart sheet, select the cells or click the chart or object you want to copy.  
2. Hold down SHIFT and click Copy Picture on the Edit menu.  
3. For best picture quality, make sure As shown on screen and Picture are selected, and then click OK.  
4. Click the worksheet or other document where you want to paste the picture.  
5. Click Paste on the Edit menu.  

To make adjustments to the image after you've pasted it, use the Picture toolbar. (To open it, point to Toolbars on the View menu 
and click Picture.)  

 

Protect Cells Using Data Validation 
Here's a creative way to protect cells in an Excel worksheet so that other users can't make changes to them:  

1. Select the cells you want to protect. (It's a good idea to make a note of the cells you protect in case you need to remove 
that protection later.)  

2. On the Data menu, click Validation, and then click the Settings tab.  
3. Set the following restrictions: In the Allow box, click Text Length; in the Data box, click between; in the Minimum box, 

type 10000; and in the Maximum box, type 50000.  
4. Click the Error Alert tab.  
5. Make sure the Show error alert after invalid data is entered check box is selected. In the Style box, click Stop.  
6. If you want a title to appear in the title bar of the message or in the Office Assistant balloon if the Office Assistant is 

displayed, type the text in the Title box. If you leave the Title box blank, the title defaults to Microsoft Excel.  
7. If you want to display your own text for the message, type the text in the Error message box, up to 225 characters. 

Press ENTER to start a new line in the message. If you don't enter any text in the Error message box, the message 
displays the following: "The value you entered is not valid. A user has restricted values that can be entered into this cell."  

Excel displays the message only when a user types data in the cell.   To remove data validation settings, select the protected cells, 
click Validation on the Data menu, and then click Clear All.  



 
 
 
 
 
 

 
Church & Ministry Technology Training Series :: Microsoft Excel 14 

 
© Copyright 2006 Netminister.net.  All Rights Reserved.   

No part of this publication may be reproduced without the written consent of Netminister. 

 

Excel Tips & Tricks for Excel 2002 (XP) 
Count Your Excel Records Based on Multiple Conditions 
Have you ever wanted a quick count of the number of records in your Excel worksheet that meet a set of conditions? Use an array 
formula. You create array formulas the same way that you create other formulas, except that you press CTRL+SHIFT+ENTER to 
enter the formula. 

Let's look at an example. Say you're running a produce department and you want to analyze your inventory to find which items cost 
more than 25¢ and have a total inventory of two items. 

Your current inventory looks like this. 

A 
B 
C 
Banana 
0.25 
2 
Pear 
0.25 
2 
Orange 
0.33 
3 
Grape 
0.5 
4 
Prune 
0.5 
5 
Apple 
0.25 
3 
Lime 
0.33 
2 
Lemon 
0.5 
4 
Kiwi 
0.5 
4 
Peach 
0.25 
3 

A1:A10 is the product name 
B1:B10 is the product price 
C1:C10 is the number on the shelf  
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Here's the array formula you'd use: 

1. In the cell where you want the results type: =SUM(IF($B$1:$B$10 > .25, IF($C$1:$C$10=2,1,0)))  
2. Press CTRL+SHIFT+ ENTER.  

This formula checks column B for values greater than .25 and, for each record meeting that condition, checks column C for values 
that equal 2. Then it adds all the records that meet both conditions. 
In the example given, the result is 1. 

 

Enter a Line Break Within a Cell 
You can control the line breaks for multiple-line headings or labels in your Microsoft Excel worksheet, just like you do in Microsoft 
Word. Here's how to do it. 

1. Click the cell where you want the label or heading to appear.  
2. Type the first line of information.  
3. Press ALT+ENTER.  
4. Type the second line. Then repeat step 3 if you have additional lines to enter.  
5. Press ENTER when you've finished typing.  

 

Perform Quick Operations on Your Excel Data 
Have you ever wanted to quickly perform an operation on your Excel data, without replacing the data? For example, maybe you 
have some yearly figures, and you want to see what the daily ones look like. It's easy to do, using the Paste Special command. 

1. Type =365 in a cell.  
2. Click Copy.  
3. Highlight the data for which you want the daily figures.  
4. On the Edit menu, click Paste Special.  
5. In the Paste Special dialog box, click Divide and then click OK.  

All of the data you have highlighted will be divided by 365. If you click in any of the cells, you'll see the operation that was performed 
displayed in the formula bar. 

 

Import Access Tables into Excel 
You've gathered the data, now you want to analyze it. Here's a quick way to copy an Access table into Excel. 

1. In the Access database window, click the table you want to export.  
2. On the Standard toolbar, click Office Links.  
3. Click Analyze It with Excel.  

Excel automatically opens and displays your table in a worksheet. 
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Another Way to Copy Access Data into Excel 
Here's an alternative way that just requires a simple copy and paste. 

1. In Access, open the table, query, or form that contains the records you want to copy.  
2. On the View menu, click Datasheet View.  
3. Select the records you want to copy. Or press CTRL+A to select the entire column.  
4. Click Copy on the File menu.  
5. Open an Excel workbook.  
6. Click the upper-left corner of the worksheet area where you want the first field name to appear. (To ensure that the 

copied records do not replace existing records, make sure that the worksheet has no data below or to the right of the cell 
you click.)  

7. Click Paste on the File menu in Excel.  

 

Import Access Data into Excel 
Did you know you could import data from your Microsoft Access databases into Microsoft Excel? Here’s a quick and easy way to do 
it: 

1. Open the Excel workbook into which you want to import the data.  
2. On the Data menu, point to Import External Data, and then click Import Data.  
3. In the Select Data Source dialog box, click New Source.  
4. In the Data Connection Wizard dialog box, click ODBC DSN, and then click Next.  
5. Click MS Access Database, and then click Next.  
6. In the Select Database dialog box, browse to the database file you want to import, and then click OK.  
7. In the Data Connection Wizard dialog box, click the name of the table that contains the data you want to import, and 

then click Next.  
8. Type a name and description, and click Finish.  
9. In the Select Data Source dialog box, click the data source you just created and then click Open.  
10. In the Import Data dialog box, specify where you want to put the data, and then click OK. (While the Import Data dialog 

box is open, you can click the row on your spreadsheet where you want the data to appear and the Existing worksheet 
box will update automatically with the correct information.)  

 

Keep Links to Source Workbooks Up-to-Date 
One of the great things about Excel is that you can create formulas in one workbook that link to data stored in another (source) 
workbook. But, when your source workbook changes regularly (for example, if you update the source and save it under a new name 
each month), it can be very time-consuming to find and update links to the old source workbook. Fortunately, there's an easy way to 
do this: 

1. Open the workbook that contains the link(s) .  
2. On the Edit menu, click Links.  
3. In the Source box, click the name of the link with the source you would like to change.  
4. Click Change Source.  
5. In the Change Source dialog box, click the source workbook you want to refer to.  

Editor's Note: To successfully change source workbooks, the linked data must reside in the same cells (for example, A15, D24) in 
the new source workbook as they did in the old. 
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Generate Random Numbers in Excel 
Some types of analysis require you to use randomly generated numbers. You can also use randomly generated numbers to quickly 
populate an Excel spreadsheet. There's an easy function you can use to do this automatically. Here are a few of the ways you can 
use it: 

• Type =RAND() in a cell to generate a number between 0 and 1.  
• Type =RAND()*100 to generate a number between 1 and 100.  

After entering a function, you can then use the fill handle to quickly populate as many cells as you'd like with random numbers. To 
use the fill handle, click the cell, move your pointer over the lower-right corner of the cell until it turns into a black plus sign, and drag 
it horizontally or vertically across the cells you wish to populate.  

Editor's Note: To change the number format of your random numbers (for example, if you'd prefer whole numbers to decimal 
points), click Cells on the Format menu. In the Format Cells dialog box, click the Number tab and then click Number in the 
Category list. Then in the Decimal places box, enter the number zero and click OK. 

 

Create Forms for Easier Data Entry 
Entering large amounts of data into an Excel spreadsheet can be very time consuming. Using data entry forms makes your task 
easier. A data entry form is a dialog box that gives you a convenient way to enter a complete row of information at one time.  

To use a data entry form to edit a list: 

1. Click a cell in the labeled row you want to add the record to.  
2. On the Data menu, click Form.  
3. Click OK. A data entry dialog box appears, with field labels that correspond with the column labels in your list.  

To add a new record 

1. Click New.  
2. Type the information for the new record.  
3. When you finish typing data, press the ENTER key to add the record.  
4. When you finish adding records, click Close to add the new record and close the data form.  

 

Keep the Result, Lose the Formula 
I receive invoices from vendors containing formulas that calculate billing data. Before I can use the billing data, I need to convert the 
formula results to plain numbers. Fortunately, in Excel it's easy to copy and paste a result without the formula. 

1. Select the cell containing data you want to copy.  
2. Press CTRL+C to copy the cell data.  
3. Press CTRL+V to paste the data in a new location.  
4. Click the arrow next to the Paste Options smart tag, and then click Values Only.  

 



 
 
 
 
 
 

 
Church & Ministry Technology Training Series :: Microsoft Excel 18 

 
© Copyright 2006 Netminister.net.  All Rights Reserved.   

No part of this publication may be reproduced without the written consent of Netminister. 

 

Use Your Spreadsheet Like a Database with AutoFilter 
You can use AutoFilter to analyze the data in your Excel spreadsheet based on specific criteria. For example, if you are a 
salesperson who has a spreadsheet listing all the clients you have in each region you cover, you can use AutoFilter to sort by a 
specific region and get a snapshot of just the clients in that region. Here's how you to use the feature: 

1. Click a cell in the list you want to filter. You should choose a cell that appears in a row that contains a heading and 
related data, such as a set of client names or phone numbers.  

2. On the Data menu, point to Filter, and then click AutoFilter. Arrows appear at the heading of each column.  
3. Click an arrow, and choose your filter criteria from the drop-down menu. (For example, you could filter for a number that's 

greater or less than a target figure.)  

Only rows containing data that meet the criteria are displayed. Great for reporting!  

Editor's Note: To see an example of AutoFilter in action, visit the How Ed Viesturs Uses Excel page, which shows how America's 
premier mountaineer uses AutoFilter to sort his packing list.  

Give Your Excel Workbooks a Consistent, Professional Look 
Most of my company's work for clients is done in Microsoft Excel. To maintain a consistent and professional look in the documents 
we send them, we created a macro that automatically formats our workbooks with certain elements. Among other things, our macro 
sets the page layout to landscape, specifies the page margins, and adds standard elements such as copyright information and page 
numbers to page headers and footers. 

Identifying repetitive tasks and recording them as macros saves us a lot of time, helps to maintain consistency, and reduces 
mistakes.  The following procedure demonstrates how to create a macro you can use to insert a custom footer into your documents. 

To create the macro:  

1. Open a new Excel workbook.  
2. On the Tools menu, point to Macro, and then click Record New Macro.  
3. In the Macro name text box, type the name for the macro, such as FormatPage.  
4. In the Store macro in list, select Personal Macro Workbook. (Note: You must save the macro in your Personal Macro 

Workbook, or it will be lost.)  
5. Click OK.  
6. On the View menu, click Header and Footer.  
7. Click the Custom Footer button.  
8. Click in the Left section, Center section, or Right section box, and then click the buttons to insert the header or footer 

information you want in that section; or, type in your own information.  
9. Click the Font button (the button with a large A) to change the font attributes.  
10. Click OK.  
11. On the Tools menu, point to Macro, and then click Stop Recording.  

To use the macro in a new document:  

1. Open a document.  
2. On the Tools menu, point to Macro, and then click Macros.  
3. In the Macro name box, click the name of the macro you want to run.  
4. Click Run.  

To view your results, click Print Preview on the Standard toolbar.  Editor's Note: To use Print Preview, you must have filled in at 
least one cell in the workbook. 
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Navigate Blocks of Data in Excel 2002 
A simple way to navigate through blocks of contiguous data in Excel version 2002 is to use the END key in combination with the 
arrow keys. To move by one block of data within a row or column, press END followed by an arrow key. For example, to move to the 
last (or rightmost) cell in a row of data, press END+RIGHT ARROW.  

Or, to move to the last cell in the worksheet, in the bottom-most used cell of the rightmost used column, press CTRL+END.  

 

Quickly Calculate a Person's Age in Excel  
The DATEDIF() function in Excel calculates the number of days, months, or years between two dates. So, this function makes it 
easy to calculate a person's age. To try this tip:  

1. In a blank worksheet, type the birth date in cell A1, using slashes to separate day, month, and year.  
2. In cell A2, type =DATEDIF(A1,TODAY(),"y") and press ENTER.  

The age (in years) will be displayed in cell A2.   Editor's Note: For more information on the proper syntax to use for the IF 
worksheet function, search for IF worksheet function in Excel Help.  

Draw Borders in Excel Worksheets 
For years Microsoft Word users have been able to create tables that meet their own unique specifications. Now, Excel version 2002 
offers users a similar feature: Draw Borders. Here's how to use it:  

1. On the Formatting toolbar, click the arrow next to Borders, and then click Draw Borders on the palette.  
2. On the Borders toolbar, click the arrow next to Draw Border or Draw Border Grid, and then click Draw Border on the 

palette.  
3. Do one or more of the following:  

1. Draw a border line on cells. Click the line you want as a border or click and drag on the lines you want as 
borders.  

2. Draw an outside border around a row. Click in the center of a cell and drag across the row.  
3. Draw an outside border around a column. Click in the center of a cell and drag down the column. 

4. When you are finished drawing borders, close the Borders toolbar to leave Draw Borders mode.  

Here are some keyboard shortcuts to use with the new Draw Borders feature:  

• To draw borders around every cell within the row or column, press the CTRL key while you drag the cursor.  
• To erase the borders you've drawn around a row or column, press the SHIFT key while you drag the cursor across the row 

or down the column.  
• To erase the borders you've drawn around every cell within a row or column, press CTRL+SHIFT while you drag the 

cursor across the row or down the column.  

Editor's Note: To apply a different line style to a border, click the arrow next to Line Style, and then click a line style on the palette. 
To apply a different line color to a border, click Line Color, and then click a color on the palette. 
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Build a Timesheet with a Simple but Powerful Function in Excel  
Excel offers a simple yet powerful way to collect employees' timesheet entries: the NOW() function. Using this function, you can 
create a macro that enables an employee to clock in or clock out with the click of a button.  

To record a macro that enters and updates the NOW() function:  

1. On the Tools menu, point to Macro, and then click Record New Macro.  
2. In the Macro name box, enter a name for the macro, such as "Timesheet".  
3. In the Store macro in box, click the location where you want to store the macro. If you want a macro to be available 

whenever you use Excel, select Personal Macro Workbook.  
4. If you want to include a description of the macro, type it in the Description box.  
5. Click OK.  
6. In the worksheet, select the cell in which the employee's clock-in time should appear, type the formula =Now(), and press 

ENTER.  
7. Copy the cell.  
8. Right-click the same cell, and click Paste Special on the shortcut menu. Under Paste, select Values, and then click OK. 

Doing this freezes the clock-in/out time so it cannot be altered by the employee.  
9. Press ENTER.  
10. On the Stop Recording toolbar, click Stop Recording.  

Now you have a macro that updates a selected cell with the current time. The next step is to assign that macro to a button, so that 
the entry can be accomplished with a single click.  

1. To create a custom toolbar button and assign the new macro:  
2. On the Tools menu, click Customize, and then click the Commands tab.  
3. In the Categories box, click Macros.  
4. Drag the Custom Button icon from the Commands box to a toolbar. Leaving the Customize dialog box open, do the 

following:  
a. Right-click the new button and then type a name, such as "ClockInOut", in the Name box on the shortcut 

menu.  
b. Right-click the new button, click Change Button Image, and then click an image. Or, to display the button 

name instead of an image, click Text Only (Always).  
c. Right-click the new button and click Assign Macro. Under Macro Name, click the name of the macro you just 

created, and then click OK. 
5. Close the Customize dialog box.  

Now all the employee has to do is select the appropriate cell and click the "Clock In/Out" button.  

 

Switch Between Absolute and Relative Cell References in Excel 
When you create a formula in Excel, the formula can use relative cell references, which refer to cells relative to the position of the 
formula, or absolute references, which refer to cells in a specific location. Formulas can also contain a mix of relative and absolute 
references. An absolute reference is indicated by the $ symbol. For example, $B$1, is an absolute reference to column B, row 1.  

When working with formulas, you can easily change column and row references from relative to absolute, and back again, using this 
handy shortcut:  

1. Select the cell that contains the formula.  
2. In the formula bar, select the reference you want to change.  
3. Press F4 to toggle through the combinations.  
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Use This Shortcut to Insert Time/Date in Excel or Access 
Here are a few keyboard shortcuts you can use to insert the current time and date in a Microsoft Access table or Excel spreadsheet.  

• Current date: Press CTRL+SEMICOLON  
• Current time: Press CTRL+SHIFT+ SEMICOLON  
• Current date and time: Press CTRL+ SEMICOLON then SPACE then CTRL+SHIFT+ SEMICOLON  

In Access, this keyboard shortcut only works if you are entering data in the Datasheet or Form view. 

Editor's Note: When you insert the date and time using this tip, the information remains static. To update this information 
automatically, you must use the TODAY and NOW functions. To learn how to do this, search for Insert the current date and time 
in a cell in Excel Help and then click Insert a date or time whose value is updated.  

 

Quickly Clear All Spreadsheet Formatting 
Here's an easy way to quickly clear all formatting in your Excel spreadsheet. 

In Excel version 2002:  

1. Click any cell in the spreadsheet and then press CTRL+A to select all cells in the worksheet.  
2. On the Edit menu, point to Clear, and then click Formats.  

 

Hide Whole Worksheets in Excel 
You can hide Excel worksheets to reduce the number of sheets on the screen and to prevent unwanted changes. When you hide 
parts of a workbook, the data disappears from view but is not deleted from the workbook.  

1. Select the sheets you want to hide.  
2. On the Format menu, point to Sheet, and then click Hide.  

Note that you will not be able to hide a worksheet if the workbook has been protected.  

 

Web Queries Keep Excel Worksheets Up to Date 
Web pages often contain information that is perfect for analysis in Excel. For example, you can use Excel to analyze stock prices 
copied directly from a Web page. But what if you need to replace the information often to keep it current? The refreshable Web 
queries now available in Excel version 2002 make that task easy.  

To create a new, refreshable Web query:  

1. In your browser, browse to the Web page from which you want to query data (such as stock quotes on MSN 
MoneyCentral).  

2. Copy the data and paste it into an Excel worksheet. A Paste Options smart tag will appear just below your pasted data.  
3. Click the arrow on the right side of the Paste Options smart tag, and click Create Refreshable Web Query.  
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4. In the New Web Query dialog box, click the yellow arrow next to table of data you want in your Web query.  
5. Click Import.  

 
Figure 8: Web Queries Up To Date 

Refreshing this data can be done manually or automatically in Excel. To do a manual refresh:  

1. On the View menu, point to Toolbars and click External Data.  
2. Then click the Refresh button on the External Data toolbar.  

To have your data refreshed automatically when the file is opened, at timed intervals, or in the background:  

1. Click Data Range Properties on the External Data toolbar.  
2. Then select the check boxes for the options you want under Refresh control.  

Editor's Note: When you retrieve data from a Web site, you might lose some formatting or content, such as scripts, .gif images, or 
lists of data in a single cell. 

 

Rest Your Eyes with Text to Speech 
Proofreading a spreadsheet can be time-consuming, blurry-eyed work, especially when you're comparing your spreadsheet against 
data in another document. But the new Text to Speech feature in Excel 2002 can really help speed up this process by reading 
selected data back to you for verification. Each cell is highlighted as the value is spoken, and when you hear an error, you can stop 
to correct the error in that cell.  
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To play back a group of cells:  

1. On the Tools menu, point to Speech, and then click Show Text To Speech Toolbar.  
2. Select a group of cells to read back.  
3. Choose how the computer will read back your data by clicking By Rows or By Columns on the Text To Speech toolbar.  
4. Click Speak Cells if you want the computer to read back each cell in your selection.  
5. To correct an error, click Stop Speaking, and use your mouse and keyboard to make the necessary changes.  
6. Click Speak Cells to continue.  

To play back after every cell entry:  

1. On the Text to Speech toolbar, click Speak On Enter.  
2. Enter data in a cell. After you press ENTER, the computer will read back the data in the cell.  

You can also specify a male or female voice and the speed of playback.  

Editor's Note: To use Text to Speech, your computer must have a sound card installed and speakers attached. The available 
voices depend on your default language installation and any language packs you may have installed. Text to Speech is not part of 
the standard installation of Excel, so have your installation CDs ready.  

 

Color-Code Your Excel Sheet Tabs 
In Excel 2002, you can color-code sheet tabs for easier identification or grouping of related sheets. Here's how:  

1. Select the sheets you want to color by holding down the CTRL key and clicking the tabs.  
2. On the Format menu, point to Sheet, and then click Tab Color. You can also right-click the sheet tab and then click Tab 

Color.  
3. Click the color you want, and click OK.  

 

Get Easy Access to New AutoSum Functions 
In older versions of Excel, the AutoSum feature was handy, but limited. In Excel 2002, the AutoSum button is linked to a longer list 
of formulas that you can add to your worksheet. With this more powerful AutoSum, you can quickly calculate the average of selected 
cells, find the maximum or minimum value in a range of values, and much more.  

1. Click the cell below the column of numbers, or to the right of the row of numbers, you want to calculate.  
2. Click the arrow next to AutoSum on the Standard toolbar, click the formula you want to use, and then press ENTER.  
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Copy an Excel Table and Its Formatting in Word 
When you copy a table of data from Excel 2002 into Word 2002, you can choose to keep the formatting that was applied to the table 
in Excel, or you can match the destination table style and your table will be formatted in the Word default table style.  

To copy a table from Excel to Word:  

1. Open both the Word document you want to copy to and the Excel worksheet that contains the table.  
2. In Excel, select the table you want to copy.  
3. On the Edit menu, click Copy.  
4. Switch to Word, and then click where you want the table to appear.  
5. On the Edit menu, click Paste.  
6. Using the Paste Options smart tag, select one of the following options:  

• To keep the formatting applied in Excel, select Keep Source Formatting. (Or, to link the table so that it 
automatically updates with new data, select Keep Source Formatting and Link to Excel.)  

• To match the style of a table already in your Word document, select Match Destination Table Style. (Or, to link 
the table instead of copying it, select Match Destination Table Style and Link to Excel.)  

 


